Старый 28.08.2012, 18:10   #1
id13
 
Регистрация: 04.12.2010
Сообщений: 22
Репутация: 1
По умолчанию 2.6.18 and prepare_kernel_cred & commit_creds

Как быть в случае с ядром 2.6.18 и например экспом http://www.exploit-db.com/exploits/15774/
Кто-то ведь уже 100% переписывал такие экспы.
Помогите ссылкой, советом и тд. )
id13 вне форума   Ответить с цитированием
Старый 29.08.2012, 10:56   #2
SynQ
 
Регистрация: 11.07.2010
Сообщений: 953
Репутация: 352
По умолчанию

Всё рядом.

Переписывания шеллкода под <2.6.29: https://rdot.org/forum/showthread.php?t=1451

Разбор этого эксплойта: https://rdot.org/forum/showthread.php?t=1479

PS На 2.6.18 он не будет работать.
SynQ вне форума   Ответить с цитированием
Старый 29.08.2012, 22:09   #3
12309
 
Регистрация: 25.12.2011
Сообщений: 265
Репутация: 33
По умолчанию

описание читал?
* This custom_method file allows to inject custom ACPI methods into the ACPI
* interpreter tables. This control file was introduced with world writeable
* permissions in Linux Kernel 2.6.33.
12309 вне форума   Ответить с цитированием
Ответ

Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход



Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd. Перевод: zCarot