PDA

Просмотр полной версии : SMB Exploit, Outpost Firewall и порт 445


winmine
01.08.2012, 01:25
Доброго времени суток, форумчане!

Возникла проблема, и я уже несколько дней не знаю, как ее решить. Может вы что-нибудь подскажете...
Ситуация следующая.
Есть машина с Windows XP SP3 без каких-либо патчей, гарантированно уязвимая к эксплоиту ms08_067_netapi. На ней стоит Outpost Firewall (версия 7.0), который почему-то блокирует порт 445.
Встроенный в Metasploit nmap выдает следующее:

Nmap: Host is up (0.00090s latency).
Nmap: Not shown: 996 filtered ports
Nmap: Port STATE SERVICE VERSION
Nmap: 139/tcp open netbios-ssn
Nmap: 445/tcp closed microsoft-ds
Nmap: 4220/tcp open
Nmap: 5230/tcp open
Nmap: MAC Address: (мак адрес)

Порт действительно закрыт. Через десяток минут после скана (фаервол может блокировать мой хост на несколько минут, если обнаружит сканирование портов) я даже проверил сниффером - при попытке создать соединение в ответ приходит TCP пакет с флагами RST, ACK.

На компе есть одна расшаренная папка, доступная всем. Однако обычным эксплорером путь \\10.1.1.3\ не открывается.
Еще у меня есть пароль к учетке администратора.

Собственно, вопрос: можно ли как-то сломать этот комп? Какие эксплоиты можно еще попробовать?

Пока что я не придумал ничего лучшего, чем ждать, пока Outpost не будет отключен и порт 445 станет открыт. Делаю это с помощью обычного пинга - если echo ответ не приходит, значит фаервол включен. Можно ли как-то автоматизировать этот процесс? Нет ли в metasploit чего-то типа запуска эксплоита раз в некоторое время?

b3
01.08.2012, 03:31
выдрать експлоит и запускать через крон.

winmine
01.08.2012, 18:14
Спасибо за совет, уже нашел, как можно запускать модули metasploit при помощи обычного bash скрипта. Но разве никакие другие эксплоиты не подойдут? Неужели для работы любого smb эксплоита нужен открытый 445 порт, и только 139 будет недостаточно?

3t3st3r
18.08.2012, 21:59
а посмотреть
show advanced

там есть пункт
Name : SMBName
Current Setting: *SMBSERVER
Description : The NetBIOS hostname (required for port 139 connections)